The last version de QuickFix need Java 8, but I can’t find info about which is the last for JDK 7, could you help me.

According to the QFJ 2.0.0 release notes they started using the Java 8 Date/Time API in that release, and it is mentioned that “You need at least Java 8 to run QuickFIX/J”. The major version was bumped because of this breaking change.

That means that the latest QuickFIX/J version supporting Java 7 should be the 1.6.4 release.