What’s a better name for this many-to-many table?
Part of one of my applications has contracts
and contract_types
tables, wherein a type may have many contracts but a contract may only be of one type. Now a new wrinkle has been introduced: a contract may change type over time (although it can, thankfully, still only be of one type at any one time).
Nice iterator naming [closed]
Closed 10 years ago.
Why does XMLHttpRequest not seem to follow a naming convention?
I’ve been working with the XMLHttpRequest object in JavaScript recently, and I couldn’t help but notice that the casing of this name makes no sense. Why is ‘XML’ all in caps while ‘Http’ is not? They’re both acronyms!
Coincidence or rule?
I was reading about Assemblies (modules, which Microsoft CLR works with). The Assembly contains so called Manifest, which by definition describes a set of files in the Assembly.
Why does the C library use macros and functions with same name?
I am reading ‘The Standard C Library’ by PJ Plauger which is really interesting. The book explains not only how to USE the library but also how it is implemented.
Order of subject and modifiers in variable names
I’m looking for experiences regarding the ordering of the subject and modifiers in variable names.
What do you call classes without methods?
What do you call classes without methods?
What are the benefits of prefixing function parameter names with p*?
I often see projects (in Java projects and teams using Eclipse) that prefix function parameters with p
.
In what language should I name my business classes?
I’m requesting best practice with this question. This is only an issue if the customer company is strictly national has a native language other than English, I think.
Naming a “do X if needed” method
What is a good way to name a method that checks if X needs to be done, and does X it if necessary?