Convention on model names in ruby on rails
I was doing my ER diagram for a rails application I’m about to begin with and there I have an entity called Class News
so I’d have a model ClassNew
but I don’t know if I will have problems in the future with the New
part or what would be the right way to do this o how should I call the model? since the right thing would be ClassNews
and the table should be class_news
…
REST API Library Conventions
Most API libraries define one method for each endpoint. If there is an endpoint for getting user information, you might have a method like:
Can someone explain to me C#’s coding convention?
I recently started working with Unity3D and primarily scripting with C#. As I normally program in Java, the differences aren’t too great but I still referred to a crash course just to make sure I am on the right track.
Do I need to use an interface when only one class will ever implement it?
Isn’t the whole point of an interface that multiple classes adhere to a set of rules and implementations?
Are there any FOSS operating systems available that conform to NASA’s JPL coding standards? [closed]
Closed 11 years ago.
Where do I place my example implementations in my framework?
I’ve created a pretty simple templating framework and have default implementations for some of my interfaces used for passing around information. I store these in MyFramework.Default namespace
Are there deprecated practices for multithread and multiprocessor programming that I should no longer use?
In the early days of FORTRAN and BASIC, essentially all programs were written with GOTO statements. The result was spaghetti code and the solution was structured programming.
Naming convention for main arguments
I recently started using arguments in my main program (here written in C++
but could be any programming language)
Naming a “do X if needed” method
What is a good way to name a method that checks if X needs to be done, and does X it if necessary?
In C and C++, what methods can prevent accidental use of the assignment(=) where equivalence(==) is needed?
In C and C++, it is very easy to write the following code with a serious error.