Redis is giving error connection refused in openwhisk

  Kiến thức lập trình

I am using k3s to deploy the openwhisk on ubuntu machine.everything is working fine except invoker pods are not able to access redis server which is running inside same namespace.

when I am trying to access the redis server from wskopenwhisk-invoker-00-27-prewarm-nodejs10 .I am getting connection refused.I have network policy.Not sure if network policy is the reason behind it.

NAME TYPE CLUSTER-IP EXTERNAL-IP PORT(S) AGE
openwhisk-kafka ClusterIP None 9092/TCP 4h21m
openwhisk-zookeeper ClusterIP None 2181/TCP,2888/TCP,3888/TCP 4h21m
openwhisk-couchdb ClusterIP 10...* 5984/TCP 4h21m
openwhisk-redis ClusterIP 10...* 6379/TCP 4h21m
openwhisk-apigateway ClusterIP 10...* 8080/TCP,9000/TCP 4h21m
openwhisk-controller ClusterIP 10...* 8080/TCP 4h21m
openwhisk-nginx NodePort 10...* 192.168.8.19 81:32498/TCP,4430:31001/TCP 4h21m

pods
NAME READY STATUS RESTARTS AGE
openwhisk-apigateway-897477798-k4ncs 1/1 Running 0 4h22m
openwhisk-wskadmin 1/1 Running 0 4h22m
openwhisk-couchdb-66dbd6585-pw75n 1/1 Running 0 4h22m
openwhisk-redis-7cbbb965b8-85cpg 1/1 Running 0 4h22m
openwhisk-zookeeper-0 1/1 Running 0 4h22m
openwhisk-kafka-0 1/1 Running 0 4h22m
openwhisk-controller-0 1/1 Running 0 4h22m
openwhisk-nginx-7889cc6f95-925sz 1/1 Running 0 4h22m
openwhisk-invoker-0 1/1 Running 0 120m
wskopenwhisk-invoker-00-27-prewarm-nodejs10 1/1 Running 0 104m

tried removing the network policy but no luck

New contributor

sagar is a new contributor to this site. Take care in asking for clarification, commenting, and answering.
Check out our Code of Conduct.

LEAVE A COMMENT