Problem When Login To Piranha CMS Manager

  Kiến thức lập trình

I deploy piranha cms from my Debian development machine to Centos 7.9.2009 server. On development machine i don’t have an issue to manager login. After login with default user dan password i directed to proper page. However, on the production server, after login to http://10.10.10.10:5010/manager the server refused to connect and i don’t even able to access http://10.10.10.10:5010/manager page again until i clear the cache. The piranha.db on development and server are exactly the same. Piranha CMS Server using kestrel on port 5010. The home page accessible normally from http://10.10.10.10:5010. All other pages also accessible but manager. Here is my website conf:

<VirtualHost *:80>
        RequestHeader set X-Forwarded-Proto "http"
        ProxyPreserveHost On
        ProxyPass / http://127.0.0.1:5010/
        ProxyPassReverse / http://127.0.0.1:5010/
        ProxyPass / http://10.10.10.10:5010/
        ProxyPassReverse / http://10.10.10.10:5010/
        ServerName kid.domain.com
        ServerAlias kid.domain.com
        DocumentRoot /var/www/kid.domain.com/public_html
        ErrorLog /var/www/kid.domain.com/error.log
        CustomLog /var/www/kid.domain.com/request.log combined
     </VirtualHost>

Any advice highly appreciated

Could this be something to do with HTTPS? I know that I had an issue logging in to my manager interface when I hadn’t realised that I was trying to access it via HTTP rather than HTTPS.

Is your server and/or your CMS requiring HTTPS somewhere along the line?

1

LEAVE A COMMENT