Need Help Identifying Error in JSON+LD in Header of WordPress SIte

  Kiến thức lập trình

When I do a URL inspection using Google Search Console, it keeps identifying an error in this custom code an SEO guy we hired put on our site through a plugin. I identified and fixed the first error, but now keep getting “Parsing error: Missing ‘}’ or object member name”. Search Console is not highlighting the problem code this time, like it did for that last error. Please tell me why I’m getting this error. It seems to indicate the problem occurs twice, at the bottom of each “sameAs” block. The custom code is:

<script type="application/ld+json">
{
  "@context": "http://schema.org",
  "@type": "MedicalBusiness",
  "name": "Sirona Therapy",
  "image": "https://www.sironatherapies.com/wp-content/uploads/2016/12/header.png",
  "@id": "",
  "url": "https://www.sironatherapies.com",
  "telephone": "(914) 241-0727",
  "priceRange": "$",
  "address": {
    "@type": "PostalAddress",
    "streetAddress": "280 N Bedford Rd #301",
    "addressLocality": "Mount Kisco",
    "addressRegion": "NY",
    "postalCode": "10549",
    "addressCountry": "US"
  },
  "geo": {
    "@type": "GeoCoordinates",
    "latitude": 41.2178324,
    "longitude": -73.71753639999997
  },
  "openingHoursSpecification": [{
    "@type": "OpeningHoursSpecification",
    "dayOfWeek": [
      "Monday",
      "Tuesday",
      "Wednesday",
      "Thursday",
      "Friday"
    ],
    "opens": "09:30",
    "closes": "19:30"
  },{
    "@type": "OpeningHoursSpecification",
    "dayOfWeek": "Saturday",
    "opens": "10:00",
    "closes": "15:00"
  }],
  "sameAs": [
    "https://www.facebook.com/sironatherapywestchester/",
    "https://www.youtube.com/channel/UC3kADQ4Bobe1VqoBWt8iLjQ",
    "https://www.linkedin.com/company/sirona-therapy/",
    "https://www.instagram.com/sironatherapywestchester/"
  ],
}
</script>
<script type="application/ld+json">
{
  "@context": "http://schema.org/",
  "@type": "Person",
  "name": "Jennifer L Zauner LCSWR",
  "url": "https://www.sironatherapies.com/",
  "image": "https://www.sironatherapies.com/wp-content/uploads/2019/08/DSCF8021-200x200.jpg",
  "sameAs": [
    "https://www.facebook.com/sironatherapywestchester/",
    "https://www.youtube.com/channel/UC3kADQ4Bobe1VqoBWt8iLjQ",
    "https://www.linkedin.com/company/sirona-therapy/",
    "https://www.instagram.com/sironatherapywestchester/"
  ],
  "jobTitle": "Owner",
  "worksFor": {
    "@type": "Organization",
    "name": "Sirona Therapy"
  },
}
</script>

I originally identified that a comma was missing at the end of the third URL in the sameAs section. When I added that, the “Parsing error: Missing ‘,’ or ‘]’ in array declaration” error finally went away, but was replaced with this new error.

LEAVE A COMMENT