Installation of Cisco Packet Tracer in Kali linux

  Kiến thức lập trình

I am trying to install Cisco PT in kali linux. I followed some online tutorials and articles but I am stuck at this step.
After downloading the .deb file, I am running the following command in the terminal:

sudo dpkg -i Packet_Tracer821_amd64_signed.deb

But there are some errors shown like:

(Reading database ... 414850 files and directories currently installed.)
Preparing to unpack Packet_Tracer821_amd64_signed.deb ...
Unpacking packettracer (8.2.1) over (8.2.1) ...
gtk-update-icon-cache: Cache file created successfully.
dpkg: dependency problems prevent configuration of packettracer:
 packettracer depends on libgl1-mesa-glx; however:
  Package libgl1-mesa-glx is not installed.
 packettracer depends on libxcb-xinerama0-dev; however:
  Package libxcb-xinerama0-dev is not installed.

dpkg: error processing package packettracer (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-icon-theme (3.12.0-5) ...
Processing triggers for shared-mime-info (2.4-1) ...
Errors were encountered while processing:
 packettracer

I am not able to install the dependencies with sudo apt install -f.

I have tried sudo apt --fix-broken install but nothing seems to work.

Do I have to rely on Ubuntu, mac or windows for this or is it still possible for me to install Cisco Packet Tracer in kali?

New contributor

user23246229 is a new contributor to this site. Take care in asking for clarification, commenting, and answering.
Check out our Code of Conduct.

LEAVE A COMMENT