This might not be easily reproduced and I am not sure if I did anything wrong. Long story short, I installed two packages r-matrix and r-matrixstats. For some other incompatibility reasons, I have to downgrade them to r-matrix=1.6_1 and r-matrixstats=1.1.0. However, since then, I have not been able to install other packages while all the failed resolving environments claim the error below. I am pretty sure (though I might be wrong) that the macs2 does not require r-matrix and r-matrixstats. Would be great if there is any suggestion for resolving such a problem.

I got the following trace:

LibMambaUnsatisfiableError: Encountered problems while solving:
  - nothing provides requested r-matrix 1.6_1.*.*
  - nothing provides requested r-matrixstats 1.1.0.*.*
  - nothing provides r 3.2.2* needed by macs2-2.1.1-r3.2.2_0

Could not solve for environment specs
The following packages are incompatible
├─ macs2 is installable with the potential options
│  ├─ macs2 [2.1.0|2.1.1.20160309|...|2.1.4] would require
│  │  └─ python [2.7* |>=2.7,<2.8.0a0 |>=2.7,<3 ] with the potential options
│  │     ├─ python [2.7.12|2.7.13|...|2.7.18], which can be installed;
│  │     └─ python [2.7.15|3.6.7|3.7.1] would require
│  │        └─ openssl >=1.1.1,<1.1.2.0a0 , which does not exist (perhaps a missing channel);
│  ├─ macs2 [2.1.1|2.1.1.20160309] would require
│  │  └─ r 3.2.2* , which does not exist (perhaps a missing channel);
│  ├─ macs2 2.1.1.20160309 would require
│  │  ├─ r 3.3.1* , which requires
│  │  │  └─ r-base [3.3.1 |3.3.1 6], which requires
│  │  │     └─ icu 54.* , which does not exist (perhaps a missing channel);
│  │  └─ r-base 3.3.1* , which cannot be installed (as previously explained);
│  ├─ macs2 [2.2.4|2.2.5|2.2.6|2.2.7.1] would require
│  │  └─ python >=3.6,<3.7.0a0  with the potential options
│  │     ├─ python [2.7.15|3.6.7|3.7.1], which cannot be installed (as previously explained);
│  │     └─ python [3.6.0|3.6.1|...|3.6.9], which can be installed;
│  ├─ macs2 [2.2.4|2.2.5|2.2.6|2.2.7.1] would require
│  │  └─ python >=3.7,<3.8.0a0  with the potential options
│  │     ├─ python [2.7.15|3.6.7|3.7.1], which cannot be installed (as previously explained);
│  │     └─ python [3.7.0|3.7.1|...|3.7.9], which can be installed;
│  ├─ macs2 [2.2.7.1|2.2.9.1] would require
│  │  └─ python >=3.10,<3.11.0a0 , which can be installed;
│  ├─ macs2 [2.2.7.1|2.2.9.1] would require
│  │  └─ python >=3.8,<3.9.0a0 , which can be installed;
│  └─ macs2 [2.2.7.1|2.2.9.1] would require
│     └─ python >=3.9,<3.10.0a0 , which can be installed;
├─ pin-1 is not installable because it requires
│  └─ python 3.12.* , which conflicts with any installable versions previously reported;
├─ r-matrix 1.6_1.*.*  does not exist (perhaps a typo or a missing channel);
└─ r-matrixstats 1.1.0.*.*  does not exist (perhaps a typo or a missing channel).

Pins seem to be involved in the conflict. Currently pinned specs:
 - python 3.12.* (labeled as 'pin-1')

For some reason, I cannot install the MACS2 with pip (I am using an institution server). Therefore, I think conda is my last hope. I also need the MASC2 in the same environment, as this is a dependency for one of the steps of the whole pipeline.

Khám phá các thẻ bài đăng