Compare two Excel spreadsheets & clean up duplicates

  Kiến thức lập trình

This is my first post here, and this is for a work-related issue.

I’ve got two datasets: “A1” (the complete set, though it has duplicate lines) and “A2” (the one I shall be using to cross reference with A1 to identify which lines are duplicates).

So, in short, I need A2 to somehow be able to highlight the duplicate lines in A1, AND THEN eliminate one of those lines in A1.

enter image description here

In this image, these are two duplicate lines in A1 which I highlighted manually, having compared with the data in A2.

I’ve tried the remove duplicates function in Excel, though it’s no use seeing as I NEED to make sure the duplicates are the ones in A2.

Have tried the INDEX function, but made no head nor tails of that one. Please bear in mind that, even though I’m not technologically-impaired, I’m by far an expert on Excel! I’ve been told you could easily do that with Python, but alas, I’ve missed that class as well 😉

Have tried this Compare two excel sheets and this is what I came up with:

=SE(ÉERRO(PROCV($E11;’Pagamentos Pix’!$E$11:$E$2015;1;FALSO)),”PGTO PIX”,””)

Didn’t work either. Hum, help?

New contributor

sublondon is a new contributor to this site. Take care in asking for clarification, commenting, and answering.
Check out our Code of Conduct.

LEAVE A COMMENT